Service Outage - Payfactors

Incident Report for Payfactors

Postmortem

Users experienced unexpected system outage between 5:12PM and 5:21PM EST due to a database error. Our teams have addressed this to ensure it does not occur again.

Posted Dec 17, 2025 - 09:07 EST

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 17:30 EST

Update

We are continuing to investigate this issue.
Posted Dec 16, 2025 - 17:23 EST

Investigating

The issue has been resolved.
Posted Dec 16, 2025 - 17:19 EST
This incident affected: Payfactors Application.